Jump to content
Sign in to follow this  
Thierry P.

[RÉSOLU] souci de serveur

Recommended Posts

Bonsoir,

Il semble y avoir un souci de serveur pour le moment, empêchant l'upload d'image dans les messages.

Les messages texte, dénués d'image, ne semblent pas affectés.

On essaie de voir d'où ça vient.

Share this post


Link to post
Share on other sites
Posted (edited)

Je signale aussi un souci de compteur de vues. Etonné de voir 0 vues sur des sujets même récents dont celui-ci. Je l'avais moi-même lu dès qu'il a été posté (et je ne suis donc pas compté, c'est terrible).

 

Mais peut-être qu'une intervention est en cours.

 

Je précise qu'il y a déjà quelques jours que perso, il m'a fallu 2 tentatives pour ajouter une vidéo sur mes derniers posts. Elles n'apparaissaient pas quand je postais et je devais recommencer une seconde fois (en m'attribuant la fausse manip).

Edited by Ciné7

Share this post


Link to post
Share on other sites
il y a 14 minutes, Ciné7 a dit :

Je signale aussi un souci de compteur de vues. Etonné de voir 0 vues sur des sujets même récents dont celui-ci. Je l'avais moi-même lu dès qu'il a été posté (et je ne suis donc pas compté, c'est terrible).

oui, c'est un problème lié. Très indirectement.

 

il y a 14 minutes, Ciné7 a dit :

Je précise qu'il y a déjà quelques jours que perso, il m'a fallu 2 tentatives pour ajouter une vidéo sur mes derniers posts. Elles n'apparaissaient pas quand je postais et je devais recommencer une seconde fois (en m'attribuant la fausse manip).

aucun rapport a priori. C'est un problème + classique qui arrive de temps en temps selon la charge serveur.

 

 

Share this post


Link to post
Share on other sites

Je confirme : comme on le voit, les messages écrits, sans photos, sont enregistrés.

Vous pouvez donc poster vos sujets mais sans photo ou alors il faut qu'elles pointent sur le Forum depuis un autre serveur. 

En revanche, les vidéos sont intégrables puisque c'est juste du code html ("texte").

 

Ca tombe un WE de Pentecôte, c'est pas le plus simple pour commander une intervention, je vous avoue. Mais c'est toujours comme ça. Cela risque de durer un moment, désolé.

 

 

 

Share this post


Link to post
Share on other sites
il y a une heure, Thierry P. a dit :

Je confirme : comme on le voit, les messages écrits, sans photos, sont enregistrés.

Vous pouvez donc poster vos sujets mais sans photo ...

Quelle chance j'ai eu de mettre mes photos ... juste avant la panne :smile: (c'était donc hier vendredi à 16 H03 ... si ça peut aider pour la recherche de l'anomalie).

Share this post


Link to post
Share on other sites

Le problème date donc de samedi après-midi. Peut-être quelque chose qui sature une partition pour une raison encore inconnue. La base de données n'est pas atteinte. Le site fonctionne normalement en Lecture.

 

Comme je l'évoquais, pour le concours du mois de mai ou tout autre besoin de poster des photos / Vidéos :

 

-Les vidéos ne sont pas touchées. Elles s'afficheront. Placez le lien comme d'habitude.

-L'upload de photos est touché. Mais au pire, si ça n'était pas réparé de sitôt, on peut poster une photo de manière détournée depuis un autre serveur. Par exemple depuis gdrive (gratuit) de Google.

 

Fonction "obtenir le lien partageable". Copier le lien.

 

Exemple :

 

https://drive.google.com/file/d/1ArD4kM2kv3E0K5MzrwMCJCukWPokhaG0/view?usp=sharing

 

Les messages de texte n'ont pas de problème (pour l'instant)

Share this post


Link to post
Share on other sites

Une intervention devrait avoir lieu dans l'après-midi.

Share this post


Link to post
Share on other sites

Résolu. :27_sunglasses2x2: Vous pouvez uploader des images comme avant.

Merci à Jean-François pour l'intervention "pompier" en plein WE de Pentecôte.

 

C'était bien une saturation d'une des partitions qui était à 0% de libre à cause de fichiers parasites.

Il fallait fouiller dans le noyau, opération toujours risquée et qui demande de bonnes compétences.

Ca se produit sans prévenir.

 

Le nombre de vue sur les sujets est aussi revenue.

Share this post


Link to post
Share on other sites

Le problème est revenu à l'instant, c'est apparement plus vicieux qu'escompté. :eusa_wall-2:

On va tenter de se repencher dessus dans un délai je l'espère plus court.

 

Pour les photos, la préconisation de passer provisoirement par le serveur gdrive (ou un autre) et de copier-coller le lien, reste donc valable. Ou de rédiger des Posts sans photos pour le moment.

 

Désolé, sauf erreur, il s'agit d'un défaut du système d'exploitation Ubuntu qui gère notre serveur informatique, pas des concepteurs du Forum ni d'une erreur de notre part. C'est la première fois que ce défaut précis se manifeste.

Share this post


Link to post
Share on other sites
Posted (edited)

Pour certaines photos de certains forums, après de nombreux tests et la fermeture de certains sites spécialisés, j'utilise https://imgbb.com/

 

1 - Une fois son image envoyée, cliquer sur "copie"

a.png

 

2 - coller le lien dans son navigateur qui ouvre l'image dans l'environnement Imgbb, alors faire d'un clique droit "copier l'adresse de l'image" qui reste à coller dans son message.

b.png

 

 

Edited by MyPOV

Share this post


Link to post
Share on other sites

"résolu provisoirement".

C'est à dire que vous pouvez replacer des photos comme avant.

Mais on est en cours de vérification que la solution trouvée (différente de la première fois) est bien la bonne.

La vérification peut se prolonger jusqu'à demain.

Merci.

(et bon lundi de Pentecôte)

Share this post


Link to post
Share on other sites

Le problème a l'air de se stabiliser, pas de nouvel incident à noter depuis 24H.

On continue de surveiller.

Share this post


Link to post
Share on other sites

Pour ceux qui adorent la technique, ou qui auraient un site Web en php ou qui veulent comprendre qu'écrire un message sur un Forum, ce n'est pas "magique", on a l'explication de ce qui s'est produit. Et du coup, bonne nouvelle, il y a peu de risque que l'on soit ennuyés de nouveau.


Des centaines de milliers de fichiers inutiles de session (360.513 fichiers pour le moment et il en reste !) se sont accumulés au fil des mois depuis un changement de version de php (php = le langage d'un serveur qui sert à écrire les fichiers). Normalement ces fichiers sont automatiquement supprimés chaque jour. Mais comme nous avions fait le choix par prudence de conserver l'ancienne version de php tout en installant la nouvelle, notre système d'exploitation (Ubuntu) "hésitait" entre l'ancienne et la nouvelle version, et dans le doute, ne supprimait plus aucun fichier inutile !

 

Il a encaissé ce trop plein jusqu'au jour (samedi dernier) où il n'a plus encaissé, faute d'espace disque. Au début du problème, le très peu d'espace qui restait (proche de 0) permettait encore d'écrire des messages texte mais pas de photos, plus lourdes que des textes et peut-être moins "fragmentables".

 

On a des contrôles d'espace disque, on voit quand ça sature mais là ça ne se voyait pas au premier coup d'oeil par les procédures habituelles.

 

J'en profite pour signaler que le contenu du Forum est sauvegardé à un rythme régulier.

 

Voilà, vous savez tout.

Share this post


Link to post
Share on other sites

Bravo et bonne nouvelle pour la résolution du problème, dommage pour vous que ce soit tombé pendant ce week-end de Pentecôte, mais dès aujourd'hui vous aller pouvoir fêter cela un buvant un coup avec le retour des terrasses des cafés.

a.jpg.f081b3a06f3669b6988014a21b73fce6.jpg

 

Par rapport au symptôme, il me semble avoir lu que des virus sous Windows saturent également les disques de fichiers au point qu'ils deviennent inutilisables, mais je me doutais bien que le site ne tourne pas sous Windows.

Share this post


Link to post
Share on other sites

J'ai eu ça il y a bien longtemps sur un forum PHPBB dont j'avais la gestion et la maintenance bien sûr, et la table sessions ne se vidait pas forcément au terme des sessions (je ne sais pas si le problème est le même ici) et bien sûr ça saturait...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...