Jump to content

Problème de rendu avec Sony Vegas Pro


Recommended Posts

Bonjour,

 

J'ai un soucis avec le rendu final de ma vidéo. En fait, j'ai réalisé une longue vidéo d'environ une heure avec un fond sonore mais seulement quelques images. Mon problème est que le rendu est très long (je n'ai même pas essayé plus de quelques minutes parce qu'il y en a pour plusieurs heures et j'ai l'intention de faire plusieurs vidéos dans ce style). Or, à moins que je me trompe, je dois pouvoir paramétrer le rendu pour qu'il soit très rapide étant donné le faible poids total des fichiers. Ai-je moyen de signaler à Sony Vegas que ce ne sont que des images et qu'il n'a donc pas besoin de comprendre cela comme une réelle vidéo ?

Merci d'avance, 

 

Benpat

Link to post
Share on other sites

Bonjour, pas spécialiste de Vegas, mais ça peut venir déjà de l'ordinateur. Sans connaître ses caractéristiques (modèle, processeur, mémoire), c'est difficile de juger.

 

La "taille" des rushes (4K ?). Ça serait bien aussi de la préciser.

Link to post
Share on other sites

Bonjour,

 

Je ne connais pas du tout Vegas Pro par contre il y a le plugin gratuit Voukoder qui lui permet d'exploiter la puissance d'encodage des cartes graphiques qui sont bien plus performantes que le CPU.

 

https://www.voukoder.org/

 

Voir ici pour la version équivalente sous Premiere Pro :

https://forum.magazinevideo.com/topic/38590-plugin-voukoder-pour-du-x264-x265-prores-etc-par-cpu-et-gpu/

 

Effectivement, le problème peut venir de photos d'une résolution bien trop grande par rapport au rendu final. Quelque que soit le logiciel, il vaut mieux les redimensionner à une taille raisonnable avant de les exploiter dans un montage vidéo.

 

Link to post
Share on other sites

Ce sont des photos en 1080p et j'ai essayé d'encoder en 720p donc je ne pense pas que ce soit énorme. Après je peux peut-être réduire le bitrate ou d'autres paramètres ?

D'accord, je vais essayer ce plugin ce soir alors, je verrai ce qu'il en est.

Merci pour vos réponses en tous cas !

Link to post
Share on other sites
Il y a 2 heures, Benpat a dit :

Ce sont des photos en 1080p et j'ai essayé d'encoder en 720p donc je ne pense pas que ce soit énorme.

oui et non. C'est un réencodage par redimensionnement de l'image. C'est pas négligeable.

 

Et les caractéristiques de l'ordinateur, vous n'avez pas précisé ?

Link to post
Share on other sites

J'ai un i5-4690 - 3,50GHz, une gtx 970 et 16go de ram

 

Je n'ai pas réussi à installer Voukoder, pourtant j'ai tout essayé, bizarre :/

 

J'ai essayé en 1080p et 30 fps, le rendu a pris 1h30 pour 4go donc j'imagine que c'est déjà pas mal ?
 

 

Link to post
Share on other sites
Il y a 6 heures, Benpat a dit :

J'ai un i5-4690 - 3,50GHz, une gtx 970 et 16go de ram

 

Sans être un monstre de puissance, je ne pense pas que le pb vienne de là à la base.

Il y a 6 heures, Benpat a dit :

J'ai essayé en 1080p et 30 fps, le rendu a pris 1h30 pour 4go donc j'imagine que c'est déjà pas mal ?

on est passé de plusieurs heures à 1H30, ais-je bien compris ?

Par contre, je crois que vous parlez d'export, le rendu c'est pas l'export. Vous parlez d'export pour parler de poids de 4 Go, n'est-ce pas ? Exporter des photos, ça peut prendre du temps car vous transformez des fichiers photo en vidéo. Les réglages sont possibles à l baisse en jouant avec le débit mais ça va pas résoudre le problème de fond.

Link to post
Share on other sites

Je ne suis pas d'accord, un i5-4690 est vraiment dépassé aujourd'hui, apparu en 2014 c'est un 4 cœurs avec seulement 4 threads, il a un passmark d'environ 5000 points tandis qu'un CPU d'aujourd'hui quelconque pour du montage vidéo est dans les 15000 soit 3 fois plus.

 

La taille n'a pas d'importance pour la vitesse d'exportation. Par contre, quelle est la durée de la vidéo exportée ?

Il faudrait une capture d'écran de la fenêtre d’exportation pour connaître les paramètres utilisés et éventuellement identifier ce qui pourrait être amélioré. A noter que la GTX970 permet d'exporter avec un encodage matériel en H264 donc c'est bien dommage de ne pas parvenir à faire fonctionner Voukoder.

 

Link to post
Share on other sites

 

Il y a 8 heures, fanfan a dit :

on est passé de plusieurs heures à 1H30, ais-je bien compris ?

Par contre, je crois que vous parlez d'export, le rendu c'est pas l'export. Vous parlez d'export pour parler de poids de 4 Go, n'est-ce pas ? Exporter des photos, ça peut prendre du temps car vous transformez des fichiers photo en vidéo. Les réglages sont possibles à l baisse en jouant avec le débit mais ça va pas résoudre le problème de fond.

 

Oui le 720p en 60 fps semblait prendre plus de temps.
Non je veux dire que la taille du fichier vidéo fait 4go après le temps de rendu d'1h30. Je ne sais pas si j'emploie les bons termes.
 

Il y a 6 heures, MyPOV a dit :

La taille n'a pas d'importance pour la vitesse d'exportation. Par contre quel est la durée de la vidéo exportée ?

Il faudrait une capture d'écran de la fenêtre d’exportation pour connaître les paramètres utilisés et éventuellement identifier ce qui pourrait être amélioré. A noter que la GTX970 permet d'exporter avec un encodage matériel en H264 donc c'est bien dommage de ne pas parvenir à faire fonctionner Voukoder.

 

La vidéo dure une heure.
Oui j'ai pourtant bien installé les deux fichiers nécessaires mais rien n'est perçu par Sony Vegas et je n'ai pas de .exe que je pourrais ouvrir avec Voukoder.

Je peux me débrouiller avec ce temps de rendu, ça n'a rien de démesuré finalement. J'ai surtout été très surpris parce que je pensais qu'une image qui ne changeait pas demandait moins de données qu'une réelle vidéo.

Link to post
Share on other sites
il y a 24 minutes, Benpat a dit :

Non je veux dire que la taille du fichier vidéo fait 4go après le temps de rendu d'1h30. Je ne sais pas si j'emploie les bons termes.

 

il y a 24 minutes, Benpat a dit :

Je peux me débrouiller avec ce temps de rendu, ça n'a rien de démesuré finalement.

 

Peu importe les termes , je vous ai compris en fait. Quand vous exportez votre fichier dont le montage totalise 1 heure, vous obtenez un fichier on va dire finalisé de 4Go et l'encodage vous prend 1H30. Ca n'a rien d'étonnant ni d'anormal je crois. Même avec des photos car il y a un recalcul. Donc en fait vous n'avez PAS réellement de problème. Vous iriez simplement un peu plus vite avec un PC plus récent, ou avec Vokouder que je ne connais pas. Mais un fichier d'une heure, ça prend quand même "un certain temps" sauf si on sacrifie le bitrate.

Link to post
Share on other sites

Le temps d'encodage ne me choque pas à la vue du CPU, ça me semble même plutôt rapide, sûrement en raison que de base ce ne sont que des photos.

 

Par contre 4Go me parait élevé pour des photos fixes, mais s'il y a des effets de zoom ou des transitions alors ça semble plus cohérent.

 

Pour Vokouder, normalement il devrait apparaître à ce niveau :

 

a.png

 

il y a cette vidéo en espagnol mais qui explique tout, étape par étape à l'écran :

 

Link to post
Share on other sites

Oui l'image n'est jamais immobile, il y a toujours un très léger effet de zoom ou dézoom, c'est peut être dû à ça.

Je n'ai pas tout à fait la même interface parce que je suis Sony Vegas Pro 2013 et je n'ai pas trouvé de vidéo d''exemple avec celui là. J'ai bien vu qu'il y avait un avant et un après 2014 pour Voukoder par contre.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By NicoTik
      Bonjour,
      Donc voila j'ai un gros problème avec le logiciel Sony Vegas pro 12 (j'avais le 11 ya 2/3 jours et ça me faisait pareil). Quand j'ouvre le logiciel et que je commence a editer, ça m'ouvre une fenetre :
       

      Et me ferme automatiquement vegas ... Si quelqu'un a une solution, je suis preneur!
      Merci d'avance 
    • By GM1968
      Bonjour,
       
      La version 15 vient de sortir... Preuve que Magix continue le développement.
       
      http://www.vegascreativesoftware.com/fr/vegas-pro/nouveautes/#productMenu
       
      Je n'ai pas encore testé. Pour l'instant, j'ai l'impression que c'est surtout un changement cosmétique. Toujours pas de suivi d'objets.
       
      J'aime bien la version 14... Je ne sais pas si je vais réellement sauter le pas.
       
    • By Thierry P.
      Depuis le 21 février 2017, Magix a sorti les nouvelles versions de VEGAS Movie Studio 14, VEGAS Movie Studio Platinum 14 et VEGAS Movie Studio Suite 14.
       


      Rappelons que VEGAS Movie Studio est un logiciel adapté aux débutants et aux amateurs avertis (les pros préfèrent la gamme Vegas pro).
       
      Vegas, produit américain (ex-Sony), a été racheté par Magix, société allemande, éditrice du fameux logiciel de montage Magix Video Deluxe. Du coup, Magix fait profiter Vegas de ses add-ons en intégrant ces derniers aux solutions Vegas Movie Studio.

      Nouvelles fonctions clés :
      - Multicam production
      - Modern User Interface
      - Improved RAM Preview
      - Trimmer window hover scrub
      - 4K monitor support

      Prix:
      - VEGAS Movie Studio 14: 49.99 €
      - VEGAS Movie Studio Platinum 14: 79.99 €
      - VEGAS Movie Studio Suite 14: 139.99 €
    • By GM1968
      Bonsoir,
       
      Nouvelle mise à jour de Vegas Pro 14
       
      https://www.vegascreativesoftware.info/us/forum/vegas-pro-14-update-7-build-270--107103/
       
      On sait jamais, on peut parfois passer à coté...
    • By Claude-Samuel Lévine
      Bonjour,
      je viens de m'abonner afin de télécharger les fichiers bruts du Sony HDR-CX900.
      Parmis ceux ci, figure un fichier audio, comportant 6 pistes enregistrées en Surround 5.1
      Or lorsque j'importe (glissé déposé) le fichier dans Vegas Pro 13, je ne comprends pas bien comment faire pour visualiser réellement les 6 pistes dans la partie audio, sous la vidéo... car je n'en vois que 2 comme s'il s'agissait d'un simple stéréo.
      J'ai bien sûr changé les propriété du projet, de "stéréo" à "surround 5.1", ceci laisse bien apparaitre le carré de panorisation / spatialisation audio entre les 5 sources, mais le nombre de piste, en face, reste à 2.
      J'ai bien aussi sélectionné "Stream 2" qui correspond dans le fichier vidéo, au mote "6 pistes". (car le fichier comporte apparament aussi, donc, un Stream 1, avec un enregistrement stéréo simple. (du coup autant activer tout le temps l'enregistrement Surround 5.1, si je comprends bien)
      La, ça me donne effectivement la possibilité de permuter l'affichage entre 6 différentes pistes, en mono, ou 3 paires stéréo, mais en aucun cas, je n'arrive à visualiser simultanémant les 6 couches des 6 pistes.
      Comment en ce cas, se rendre compte si à un endroit précis, il y aurait des pics trop élevés (saturations) à part à l'oreille ?
      Comment savoir aussi, si le résultat final sortirait bien spatialisé correctement ?
      étant NOVICE en terme de Surround 5.1, que je découvre en découvrant le camescope HDR-CX900... je me pose la question à savoir si, le surround 5.1 ne consiste pas en 2 pistes stéréo + des sortes de codages de "différences" que les autres micros arrières se contenteraient d'indiquer dans le fichier ?
      ou bien y'a t'il dans le fichier réellement 6 pistes audio indépendantes en plus du stream vidéo ?
      ( Bon, en même temps c'est plutôt à titre de simple curiosité, ne disposant pas d'un home cinéma, et ne connaissant absolument personne dans mon entourage disposant de ce genre d'installation, je me contenterai du bon vieux stéréo... )
    • By Claude-Samuel Lévine
      Bonjour,

      cela fait plusieurs années que je monte sous Vegas... et je viens seulement de soulever un lièvre. Voilà l'histoire :
      Personnellement j'optimise encore aujourd'hui mes vidéos pour une qualité finale en... DVD ! Oui vous me lisez bien : je pense encore au bon "vieux" DVD, en 720 x 576 ( je sais bien qu'aujourd'hui "vieux" veut dire > 2 ou 3 semaines. Alors un dinosaure sorti avant l'an 2000, c'est la machine de l'atlandite... ) Pour quelle raison ce choix ? Parce que je pense aux autres, quand je réalise un truc, or les gens chez moi, dans mon entourage, n'ont pas de lecteur blueray, pas forcément le dernier PC ou le dernier MAC HD, pas forcément le dernier écran 4K courbe du dernier Salon du Geek. En revanche ils ont presque tous un lecteur de DVD. ( Je ne parlerai pas des irréductibes cloitrées sans télé, sans ordi.. )

      Ce choix me permet d'utiliser quelques zoom numériques dans la belle résolution HD... sauf que je remarque certains défauts d'aliasings. Je sais bien que c'est logique de trouver de l'aliasing lors d'un zoom numérique dans une vidéo, mais l'aspect me semble pourtant plus prononcé qu'à la normale. Cela me semble descendre en dessous de la qualité du VHS d'antan.
      Cela dit pas trop de zoom numériques non plus, car je pense aussi HD et Youtube, et aussi futur. Ces recadrages restent donc ponctuels.


      Mais mon intuition m'a indiqué d'essayer du côté des modes de prévisualisations rapides :
      Brouillon / Prévisualisation / Optimisé :
      je viens de faire plusieurs essais concluants et suprprenants, qui vont à l'encontre de la logique même ! Voici en guise de conclusions 2 captures d'écrans, vous pourrez vous rendre compte par vous même de la différence entre 2 captures d'écran, et en tirer la conclusion qui s'impose d'elle même. ( observez bien l'aliasing sur les touches du clavier )

      Dans tous mes nouveaux projets, je choisirai dans le cadre :
      "Qualité rendu en res. intégrale" = Prévisualisation et non plus "Optimisé".
      Le rendu lui même se fait d'ailleurs plus rapidement, en évitant ces calculs supplémentaires qui n'apportaient qu'aliasing et pixélisations ! ( attention : le mode "Brouillon" est lui toutefois vraiment moins bon. oui j'ai même songé à l'essayer, mais le choix optimal est bien "Prévisualisation" qui est la qualité n°2 sur les 4 choix possibles. )





    • By docteurdread
      Bonjour à toute la communauté ! ;)
      J'ai commencé il y a un moment ma chaîne YouTube et comme vous vous en doutez, je réalise donc des vidéos ! :bravo:

      Comme dit dans le titre, j'ai un énorme problème:
      Je tourne mes vidéos sur le jeu "Minecraft" à l'aide du célèbre logiciel "Fraps".
      Donc j'enregistre et tout se passe nickel, la vidéo enregistrée est de bonne qualité, ce qui est tout à fait normal.
      Ensuite, je fais mon petit montage sur Sony Vegas 11 et je rends en ".mp4" à l'aide de "MainConcept AVC".
      ==>Mais voici le résultat (même qualité sans upload sur YouTube), très médiocre voire même très mauvais:


      Comme vous le voyez, le résultat n'est pas celui attendu ^^
      Je vais donc vous montrer mes réglages:

      1)L'enregistrement
      J'enregistre avec "Fraps" et avec mon jeu à la résolution 854x480 (celle de YouTube). Je tiens à dire que la résolution va rester 854x480 après le montage donc aucun changement. Ayant une petite connexion, je ne peux pas me permettre du 720p :hum:
      Voici 2 images de la config. de Frapsou:




      Comme dit plus haut, la qualité après enregistrement est excellente

      2)Le montage avec Sony Vegas Pro 11
      Le montage avec Vegas est très bref: j'ajoute une intro.
      Ensuite, je rends avec ces paramètres:





      Bref, je laisse le nombre de fps de départ et je mets comme débit binaire 2500kb/s en moyenne et 4000kb/s maximum.
      or YouTube indique ceci:




      Donc voilà, je vous remercie déjà d'avance


×
×
  • Create New...

Important Information

j'accepte les cookies de ce site