Jump to content
Télémac

entrelacement à l'exportation séquence Autonome comme en H264

Recommended Posts

Bonjour

le contexte et le matériel:

Captation : panasonic TM300 en AVCHD 1920 x 1080/50i

FCE 4.x réglé en configuration simplifiée : AIC 1920x1080i50

( FCE ne propose le Progressif que du AIC 720 P)

Snow léopard

montage image pas de problème :

2 exportations :

- vers séquence quicktime H264

- séquence autonome ( pour en pas perturber ce post, merci de ne pas répondre sur le choix de cette option, sur ce point je lance cette question dans un autre post)

Problème rencontré :

Présence de tries visibles sur les fichiers exportés

solution:

Dans FCE placer le filtre désentrelacer sur le montage de la timeline avant exportation et dans ce cas les stries ne sont plus visibles.

Question :

Comment rester dans FCE en AIC 1920 x 1080 Progressif sans devoir chaque fois avant exportation utiliser le filtre désentrelacement?

La solution MovieConverter pour passer des fichiers source MTS en 1920x 1080 progressif et importer seulement ensuite les fichiers dans FCE pose deux remarques :

1) 3 caméscopes avec 3 heures de spectacles cette solution donne une méthode très longue d'encodage et de récupération des fichiers dans FCE.

2) pour avoir testé une séquence courte et après vérification avec le logiciel VideoSpec, celui ci m'informe que : entrelacement : non défini :smile:

Share this post


Link to post
Share on other sites

Complément d'information pour étayer mon propos ci-dessus

J'ai exporté la même séquence 6x

- séquence autonome (sans filtre)

- H264 (sans filtre)

- séquence autonome avec filtre désentrelacement paire inférieure

- H264 avec filtre désentrelacement paire inférieure

- séquence autonome avec filtre désentrelacement impaire supérieure

- H264 avec filtre désentrelacement impaire supérieure

Il est anormal de devoir appliquer un filtre de désentrelacement si on filme en progressif, ceci étant voici mes constats:

Info avec logiciel VideoVpec

- séquence autonome (sans filtre)

entrelacement : non défini

- H264 (sans filtre)

entrelacement : non défini

- séquence autonome avec filtre désentrelacement paire inférieure

entrelacement : non défini

- H264 avec filtre désentrelacement paire inférieure

entrelacement : progressif

- séquence autonome avec filtre désentrelacement impaire supérieure

entrelacement : non défini

- H264 avec filtre désentrelacement impaire supérieure

entrelacement : progressif

Comparons maintenant les séquences. Celles sans filtre de désentrelacement il y a un reflet autour de la personne (éventuellement avancer image par image) et cet effet n'existe pas sur les séquences ou j'ai appliqué dans FCE le filtre de désentrelacement.

dans les deux cas ci-dessous, l'effet est visible que ce soit en autonome comme en H264

- séquence autonome (sans filtre)

entrelacement : non défini

séquence autonome sans filtre

- H264 (sans filtre)

entrelacement : non défini

exportation en H264 sans filtre

dans les cas ci-dessous, l'effet est invisible que ce soit en autonome comme en H264

- séquence autonome avec filtre désentrelacement paire inférieure

entrelacement : non défini

séquence autonome filtre désentrelacement paire inférieure

- H264 avec filtre désentrelacement paire inférieure

entrelacement : progressif

H264 avec filtre désentrelacement paire inférieure

- séquence autonome avec filtre désentrelacement impaire supérieure

entrelacement : non défini

séquence autonome avec filtre désentrelacement impaire supérieure

- H264 avec filtre désentrelacement impaire supérieure

entrelacement : progressif

H264 avec filtre désentrelacement impaire supérieure

lien direct pour télécharger les fichiers

A ce stade du constat, séquence autonome ou H264 même problème : effet d'entrelacement se matérialisant sous une forme ou une autre pas obligatoirement sous forme des stries classiques.

Share this post


Link to post
Share on other sites

Complément des problèmes rencontrées sur cette question

Séquence autonome sans filtre de désentrelacement.- pas de strie mais effet "halo" visible autours de l'acteur

post-98-1286801830_thumb.png

A certains moment (pas toujours) il y a un changement de couleur entre deux images voir comparaison ci dessous)

post-98-1286801840_thumb.png

post-98-1286801852_thumb.png

En exportation H264 présence de stries avec filtre comme sans filtre

post-98-1286802135_thumb.png

Pour que la question soit complète, le dernier défaut relevé concerne la séquence effet pompage zoom ( dès que je peux récupérer le fichier je le place en ligne)

Share this post


Link to post
Share on other sites

Après de nombreux tests voici la situation

Fichier originaire du Pana TM300 filmé en 1920 x 1080 x 50i

VideoSpec m'informe que les fichiers .ts :

- Entrelacement : entrelacé - trame supérieure d'abord

FCE travaille en 1920 x 1080 50I

1) exportation en séquence autonome de FCE

VideoSpec m'informe :

- Entrelacement : non défini

J'ouvre ce fichier avec

-Quicktime (à l'image j'ai un effet de pompage très rapide de zoom) .

-VLC refuse de l'ouvrir

Présence de stries dans :

-Starfire

-Movie converter

- MpegStreaming

- Avchd Converter

Avec iDvd pas de problème le fichier ne pompe pas ni ne présente des stries.

2) exportation de FCE en H264 non désentrelacé

VideoSpec m'informe :

- Entrelacement : progressif

Mais toujours la présences de stries dans tous les logiciels

3) application dans FCE d'un filtre désentrelacement et reexportation de FCE :

en séquence autonome comme en H264, plus d'effet de pompage ni de présence de stries.

Share this post


Link to post
Share on other sites

Re en ce samedi matin etc... (voir au post de dragonvideo).

La seule chose que je puisse dire, c'est que l'on a toujours des stries à la lecture sur l'écran du Mac.

L'important étant qu'elles n'existent pas sur un écran de téléviseur, et c'est la cas.

Que veux-tu dire par : "à l'image j'ai un effet de pompage très rapide de zoom" ?

Cordialement.

Share this post


Link to post
Share on other sites

Avec un fichier H264 sur la station multimédia connexion HDMI au TV plasma et sur un vidéoprojeteur j'ai le même problème de strie. ( n'existe pas si je passe en connexion analogique péritel ou uShiden et c'est logique)

Le fichier H264 placé sur Vimeo ou Dailymotion, s'il n'est pas désentrelacer, les stries sont visibles tant sur le mac que sur le PC (logique puisque nous sommes devant un écran

Le fichier séquence autonome n'est pas lisible sur le TV ce qui est normal ce n'est pas un format de compression/diffusion comme le H264.

Effet zoom coup de point, sans stries de visibles, et généré aléatoirement et principalement après un changement de plan. Juste avant il change de couleur voir JPEG ci-dessous comparatif. (

post-98-1287207148_thumb.jpg

Effet zoom avant arrière effet tremblement de terre à l'écran.

post-98-1287207982_thumb.jpg

Phénomène généré que dans quicktime séquence autonome non désentrelacé pas avec les autres logiciels de cités qui eux génèrent les stries.

Précision : les séquences autonomes DV Pal qui sont aussi entrelacés ce phénomène n'ést pas généré.

Share this post


Link to post
Share on other sites

Bonjour à tous en ce dimanche de repos.

Bon, je vois un peu mieux ce que tu veux dire. Ne pourrais-tu mettre un fichier en ligne ?

Cordialement.

Share this post


Link to post
Share on other sites

Je fais les tests de compression car les 20 secondes pèsent très lourd.

A mon avis l'entrelacement du Pana TM300 et de l'AIC-50I de FCE doivent perturber quicktime. Cette perturbation je l'affecte en première hypothèse à la question de gestion d'affichage de l'entrelacement lignes impaires et paires selon les formats.

Share this post


Link to post
Share on other sites

Si on a une approche logique :

1) Première question le Pana TM300 AVCHD capture et sauvegarde-t-il en progressif?

Selon le manuel page 154 voici les tailles de l'image :

HA/HG : 1920 x 1080/50i

HX: 1920x1080/50i

HE:1440x1080/50i

réponse il semblerait que non.

2) constat:

Pana TM300 AVCH 1920x 1080-50I= entrelacé

FCE liste et transfère en 1920 x 1080-50i = entrelacé

la séquence autonome est.... selon le logiciel VideoSpec : entrelacement non défini = quicktime qui "fait des siennes" et les autres logiciels cités présentes des tries.

Si on exporte en H264 VideoSpec annonce entrelacement progressif mais présences de stries.

Dans la mesure ou FCE n'autorise pas lors de l'opération "lister et transférer" d'avoir du progressif en 1920 x 1080 AIC. il n'y a ce stade de tests que deux solutions qui deviennent des contraintes:

A) Utiliser Movie converter ou MepgStreaming et convertir les fichier .ts du Pana en AIC 1920 x 1090 50P

( mais je ne sais pas comment la séquence autonome va se comporter ensuite après être passé dans FCE en 50I)

2) appliquer comme je l'ai fait le filtre de désentrelacement dans FCE.

Il faut constater que dans ces conditions ce sont des contraintes et des temps de calcul supplémentaire.

L'idéal restant de pouvoir directement dans FCE "lister et transférer" en P les fichiers sources du TM300

Share this post


Link to post
Share on other sites
1) Première question le Pana TM300 AVCHD capture et sauvegarde-t-il en progressif?

réponse il semblerait que non.

Sauf que ces deux fichiers MTS, pris avec le TM300, montrent bien - à l'oeil - une différence nette :

quelque chose qui ressemble fortement à de l'entrelacé dans le 1er cas (entrelacement prononcé)

quelque chose qui ressemble fortement à du progressif dans le 2e cas (pas d'entrelacement).

Les images ont bien été prises avec un TM300.

le second mode a été obtenu avec le mode Cinema numérique.

post-10-1287322070_thumb.jpg

C'est assez criant en images arrêtées :

post-1-1287322612_thumb.jpg

entrelacé

post-1-1287322649_thumb.jpg

progressif (mode Cinema numérique ou Digital Cinema en anglais)

Share this post


Link to post
Share on other sites

Page 68 du manuel j'ai effectivement relevé cette information qui ne me semblait pas traiter de cette question d'entrelacement(i) ou progressif .

En effet je lis que le manuel (jpeg ci dessus)

1) parle de couleur plus éclatante

2) parle d'un enregistrement en 50i (et pas d'un enregistrement en 50p)

3) parle en page 105 des sorties.

post-98-1287324793_thumb.jpg

Fort de ces rapprochements d'informations, j'ai pensé que cela ne concerne pas ma question d'enregistrement en progressif mais juste de diffusion sur un TV.

Ceci étant ta comparaison d'image est intéressante et pourrait répondre a mon attente aussi je viens de filmer quelques seconde dans ce mode.

Je fais le test et reviens avec les conclusions.

Share this post


Link to post
Share on other sites

Comparatif fichier ;TS

post-98-1287325865_thumb.jpg

mode cinema

Le rapport dans VideoSpec semble confirmer le manuel : enregistrement bien en I et pas en P

- Entrelacement : entrelacé - trame supérieure d'abord

post-98-1287325951_thumb.jpg

mode normal

Le rapport dans VideoSpec précise : enregistrement en I

regarde sur le devant du porteur on voit les stries.

en mode cine le bord semble plus lisse

post-98-1287327720.png

alors qu'en normal il semble y avoir des "escaliers"

post-98-1287327754.png

(PS sur les gros plans "cheval" et acteur c'est plus visibles que sur les présents plans larges)

Test suivant dans FCE

Share this post


Link to post
Share on other sites

Salut,

Plusieurs points :

- pour vérifier l'entrelacement, il faut que le sujet bouge horizontalement.

- souvent, le progressif est "emballé" dans un fichier entrelacé. VideoSpec le montre : même la captation en progressif se retrouve dans un fichier apparaissant comme entrelacé. Mais les deux trames ont été prise en même temps et non 20 ms plus tard. Cela se VOIT sur l'image.

Antoine

Share this post


Link to post
Share on other sites
Salut,

Plusieurs points :

- pour vérifier l'entrelacement, il faut que le sujet bouge horizontalement.

- souvent, le progressif est "emballé" dans un fichier entrelacé. VideoSpec le montre : même la captation en progressif se retrouve dans un fichier apparaissant comme entrelacé. Mais les deux trames ont été prise en même temps et non 20 ms plus tard. Cela se VOIT sur l'image.

Antoine

Certes ceci je l'entends, mais pouvons nous en déduire à la lecture de cette précision que si nous capturons en mode cinema et même si FCE est configuré en entrelacé, le fichier exporté sera quand même du progressif pas besoin d'appliquer le filtre désentrelacer pour contourner les problèmes rencontrés((voir plus haut) ?

Si l'entrelacement est bien visible sur les jpegs ci-dessus sur des sujets filme en gros plan (cheval, actrice), effectivement sur les plans larges de mon présent test, on ne constate quasi rien sur la vidéo.

Pour les séquence autonomes de ces nouvelles séquences Plan large mode cine ou mode normal, VideoSpec donne les mêmes infos : - Entrelacement : entrelacé - non défini

Share this post


Link to post
Share on other sites
Comparatif fichier ;TS

post-98-1287325865_thumb.jpg

mode cinema

Le rapport dans VideoSpec semble confirmer le manuel : enregistrement bien en I et pas en P

- Entrelacement : entrelacé - trame supérieure d'abord

post-98-1287325951_thumb.jpg

mode normal

Le rapport dans VideoSpec précise : enregistrement en I

regarde sur le devant du porteur on voit les stries.

en mode cine le bord semble plus lisse

post-98-1287327720.png

alors qu'en normal il semble y avoir des "escaliers"

post-98-1287327754.png

(PS sur les gros plans "cheval" et acteur c'est plus visibles que sur les présents plans larges)

Test suivant dans FCE

j'ai eu beau relire 3 fois, je n'ai pas compris à quelle conclusion tu veux en arriver.

d'autant qu'en plus, l'exemple n'a rien à voir puisque tu as choisi un sujet apparemment fixe qui ne permet pas de voir correctement s'il y a effet de peigne ou pas…

également : laissons Videospec de côté si tu le veux bien, ça embrouille car on a déjà en jeu le mode choisi sur le camescope (Cinema ou pas Cinema), le montage sur Final Cut, et l'application d'un filtre ou pas (plus éventuellement la façon dont tu sors le fichier en sortie de montage).

J'évoque ce qu'on voit à l'image de façon ostensible sur l'exemple des chevaux et qui a été capté par un TM300… C'est l'image brute, je ne l'ai pas inventée, la 2e est plutôt de type Progressif.

Share this post


Link to post
Share on other sites

Ouf... 3 questions dans la même phrase.

Si la capture est progressive, la vidéo reste progressive. Que le conteneur soit marqué entrelacé, c'est pour ne pas perturber les logiciels standards.

Si l'export est fait en progressif, le conteneur sera cohérent avec le contenu. Si l'export est entrelacé, ce sera une vidéo progressive dans un conteneur entrelacé. C'est ce que fait le caméscope.

Pourquoi désentrelacer un vidéo progressive ? L'effet du filtre sera inutile et pourrait légèrement dégrader l'image.

Antoine

Share this post


Link to post
Share on other sites

Les copies d'écran viennent de fichier.ts

ou je veux en arriver dans le sens de ta démonstration.

CAD, regarde les petites imagettes découpées du plan large, on voie l'effet escalier sur la séquence filmée en mode nomal, et cet effet n'est pas présent dans le mode ciné. (certes en filmant en gros plan les stries sont mieux visibles)

Cet escalier correspond bien aux stries de ton cheval et de mon actrice, puisque cet effet disparait dans VLC lorsque j'active l'option : désentrelacement Oui ou automatique.

Malgré que le manuel n'est pas très explicite, ton constat semble être la bonne : il faut filmer en mode ciné

( je ferais le test en condition gros plan)

Share this post


Link to post
Share on other sites
ou je veux en arriver dans le sens de ta démonstration.

j'étais tenté de penser exactement le contraire puisqu'il te suffisait de dire, oK, le cheval est démonstratif plutôt que de montrer un second exemple, moins frappant.

Je croyais donc que tu voulais montrer un exemple contraire… :blush: Enfin, je ne savais plus trop, c'était pas clair…

Share this post


Link to post
Share on other sites
Ouf... 3 questions dans la même phrase.

Si la capture est progressive, la vidéo reste progressive. Que le conteneur soit marqué entrelacé, c'est pour ne pas perturber les logiciels standards.

Ok c'est clair mais ceci perturbe l'utilisateur :blush:

Si l'export est fait en progressif, le conteneur sera cohérent avec le contenu. Si l'export est entrelacé, ce sera une vidéo progressive dans un conteneur entrelacé. C'est ce que fait le caméscope.

Je recadre le tout

Au départ le caméscope capture en 1920x1080 50i, tu dis que cela peut être du progressif encapsulé dans du I.

OK j'entends. mais pourquoi alors j'ai tous ces pépins (voir le début de ce post en première page) sauf si j'applique avant l'exportation le filtre de désentrelacement.?.

Suite à cela, Pixel précise qu'en mode cine les stries ne sont pas visibles sur son cheval filmé dans ce mode et mon test va aussi dans son sens.

Pourquoi désentrelacer un vidéo progressive ? L'effet du filtre sera inutile et pourrait légèrement dégrader l'image.

Donc le mode cine étant du progressif encapsulé dans du i, effectivement inutile d'ajouter le filtre de désentrelacement (dégradation de l'image et je me retrouve en plus dans mon cas 1 à problème)

Share this post


Link to post
Share on other sites
j'étais tenté de penser exactement le contraire puisqu'il te suffisait de dire, oK, le cheval est démonstratif plutôt que de montrer un second exemple, moins frappant.

Je croyais donc que tu voulais montrer un exemple contraire… :blush:

J'entends et tu as raison, cela aurait été plus simple de dire oui et la simple phrase

en mode cine le bord semble plus lisse
bien qu'implicitement allant dans ton sens n'était pas explicite.

Et comme mes différents essais généraient aléatoirement mes problèmes dont je parle, j'ai refait les tests :think:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...