Jump to content

Photos écran noir dans Imovie, pourquoi ?


Recommended Posts

On aurait dû essayer plus tôt.

Je n'ai rencontré aucun problème pour récupérer et incorporer tes photos dans un montage. Le mystère s'épaissit. Et ce serait dommage de s'en priver (des images, le mystère on s'en passerait).

Essaye dans un premier temps de récupérer ces photos dans zupimages pour voir. Qui sait ?

Si rien ne s'améliore, suit le conseil de JLB 21 :

"Enfin, as-tu essayé de mettre à la corbeille ton application iMovie 10.app et de la re-télécharger depuis l'onglet Achat de l'App Store ?"

Pas de difficultés particulières.

La recharge d'El Capitan est un peu plus délicate pour qui n'a jamais pratiqué ; je l'ai faite avec l'assistance d'Apple. Si tu le fait avec eux, vérifie que tu récupères bien tes bibliothèques et tes projets avant de raccrocher :laugh:.

Link to post
Share on other sites
  • Replies 71
  • Created
  • Last Reply

Top Posters In This Topic

D'accord mais est-ce qu'en lisant le projet avec ces deux photos, tu les vois à l'écran lors de la lecture ?

Oui je crois que je vais tenter d'intégrer ces photos téléchargées et si besoin re-télécharger Imovie 10...

Link to post
Share on other sites

Alors pour info : dans Imovie 10, lorsque je glisse les 2 photos (qui étaient sur le bureau) directement dans la time line, une des deux se lit parfaitement, l'autre non

Link to post
Share on other sites

Ah surprise, celle qui ne lisait pas, se lit maintenant...Lui fallait-il un temps d'adaptation dans l'insertion du projet ?

Je n'y comprends rien..

Et pourquoi ces 2 photos téléchargées se lisent alors que celles présentes dans mon Mac ne veulent pas se lire...? :eusa_wall:

C'est à n'y rien comprendre...Je ne vais quand même pas les stocker une par une sur internet ? J'en ai au moins 400 !!! :eusa_pray: Lol

Link to post
Share on other sites

Bon, chez moi les deux photos s'affichent correctement dans le visualisateur de iMovie 10, y compris en lecture plein écran.

Vues dans Aperture, il n'y a aucune information Exif, ce qui signifie qu'elles ont été retouchées, dans quel logiciel ? La m6ve est au format 3:2, la 2yvw au format 4:3. Avec la définition et le poids, la date (sans doute de traitement dans un logiciel de retouche), aucune autre information.

Quand je dis que je n'ai jamais de problème de ce genre dans iMovie (lors d'essais puisque j'utilise FCP X), mes photos sont nature, avec quelques retouches non destructives de leurs métadonnées dans Aperture.

Une autre chose, c'est leur poids. Ce qui est possible, c'est que ta machine soit un peu faible (RAM, processeur) pour gérer dans iMovie des photos de ce poids, surtout dans ton cas où, si je ne m'abuse, il s'agit d'un diaporama.

Lorsque j'ai à rentrer un certain nombre de photos dans FCP X, destinées à être traitées en diaporama sur la timeline, avec ou sans plugin spécialisés, j'ai pour habitude de les réduire en taille préalablement, la plus grande dimension étant égale ou légèrement supérieure (en cas de zoom envisagé) à la largeur de ma vidéo, 1 080 pixels, et en résolution 100 dpi maxi.

Il faut en effet savoir qu'en vidéo, la résolution (nombre de pixel par unité de surface, n'apporte absolument rien à la qualité du film exporté. Des photos de poids élevé n'ont donc pour conséquences que d'alourdir inutilement le montage, parfois de façon rédhibitoire.

Il est fort possible, mirabella, que ton problème résulte du fait que, disposant d'une machine un peu 'légère' et traitant un grand nombre de photos, de poids/définition élevée, iMovie soit incapable de gérer l'affichage correct de tous les fichiers présents sur la timeline.

Après, pourquoi certaines photos sont-elles affichées correctement et pas les autres, à ta place, je ne me poserais pas la question.

Essaie déjà de vérifier mon hypothèse… En commençant par réduire la dimension d'une photo que 'ne passe pas' et de vérifier si elle devient visible.

Link to post
Share on other sites

Ah c'est intéressant...En effet, je pense avoir une machine peu puissante par rapport à Imovie et El Capitan, il faudrait que je rajoute un peu de mémoire, je tourne à 2 Go :mellow:

Mais enfin, c'est vrai que c'est suffisant sauf pour des retouches vidéos...Oui je voudrais faire un diaporama avec du son mais j'ai besoin d'imovie car je veux caler ma musique de telle façon à tel endroit, etc..;et iPhoto ne me permet pas de faire cela...

Je serai d'accord pour réduire la taille des images, comment faire ? Via iPhoto ?

Je vous indique que ces photos n'ont subi aucun traitement, ce sont les photos d'origine que j'ai dû récupérer auprès de la personne concernée. Ce sont pour ainsi dire les photos de base mais qui ne proviennent pas du même appareil photo...

Link to post
Share on other sites

Et puis si je suis ta logique JBL, comment se fait-il que sans avoir réduit la taille, en stockant simplement la photo sur internet (pour que vous puissiez la voir) et en la téléchargeant dans mon Mac, elle s'ouvre et se lit parfaitement.

Cette même photo, sans avoir été chargée sur le web puis téléchargée, ne se lit pas.

C'est cela l'incompréhension car ici, aucune réduction de taille n'a été effectuée...

Link to post
Share on other sites

Je continue à chercher.

Récapitulons :

1 - Les photos qui posent problème proviennent du même appareil. Toutes les photos provenant de cet appareil ne posent pas problème.

2 - Elles sont au nombre de deux.

3 - Ta version d'iMovie est la 10.1 (pas la 10.0)

4 - Elles apparaissent dans la Time Line mais sont noire à la lecture.

Ta config pour iMovie 10 est légère effectivement. Mais n'explique pas pourquoi tu rencontre le même problème avec iMovie 9, mois gourmande en mémoire.

Link to post
Share on other sites

Pour réduire la taille d'une photo, c'est dans Aperçu : outils/ajuster la taille

Autre chose, plutôt que faire glisser tes photos du bureau à la Time Line, passe par la commande : fichier/importer des médias. pour voir...

Link to post
Share on other sites

Et puis si je suis ta logique JBL, comment se fait-il que sans avoir réduit la taille, en stockant simplement la photo sur internet (pour que vous puissiez la voir) et en la téléchargeant dans mon Mac, elle s'ouvre et se lit parfaitement.

Cette même photo, sans avoir été chargée sur le web puis téléchargée, ne se lit pas.

C'est cela l'incompréhension car ici, aucune réduction de taille n'a été effectuée...

Cela, ce sont les mystères (à mes yeux) de l'informatique. Mon coté intuitif dû à ma longue fréquentation de la micro et du web* me font faire des expériences qui portent parfois leurs fruits :w00t:.

Dans le cas de tes photos, on peut supposer que le passage par le web a éliminé les scories d'un fichier légèrement dégradé ou perturbé.

Si j'ai bien suivi, les photos incriminées proviennent d'un même appareil. C'est peut être de lui que vient le problème. Lui ou de sa carte mémoire. Lorsque tu as rechargé ces photos, tu l'as fait avec la carte mémoire originale ?

Si j'ai bien suivi, tu ne rencontrais pas de problèmes avant ton passage à EL Capitan et iMovie 10.1

Le fait qu'iMovie 9 soit également perturbé semble incriminer El Capitan plutôt qu'iMovie 10.1.

El Capitan aurait des problèmes avec des photos peut être légèrement dégradés. (Ou aurait besoin d'une mémoire importante, mais j'y crois moins).

Il serait intéressant d'avoir l'expérience de quelqu'un qui serait passé à El Capitan et resté à iMovie10.0

Et oui, je lis bien tes photos dans iMovie à la lecture et en plein écran.

(* non pas en tant qu'informaticien mais de formateur à l'utilisation d'applications informatiques ou de concepteur de formations sur internet).

Link to post
Share on other sites

Ah c'est intéressant...En effet, je pense avoir une machine peu puissante par rapport à Imovie et El Capitan, il faudrait que je rajoute un peu de mémoire, je tourne à 2 Go :mellow:

Mais enfin, c'est vrai que c'est suffisant sauf pour des retouches vidéos...Oui je voudrais faire un diaporama avec du son mais j'ai besoin d'imovie car je veux caler ma musique de telle façon à tel endroit, etc..;et iPhoto ne me permet pas de faire cela...

Je serai d'accord pour réduire la taille des images, comment faire ? Via iPhoto ?

Je vous indique que ces photos n'ont subi aucun traitement, ce sont les photos d'origine que j'ai dû récupérer auprès de la personne concernée. Ce sont pour ainsi dire les photos de base mais qui ne proviennent pas du même appareil photo...

Si, elles ont été nécessairement traitées dans un logiciel externe puisqu'elles ne possèdent plus aucune métadonnées.

Ci dessous les métadonnées d'une photo normale et celles (inexistantes) de l'une de tes photos :

post-14021-0-38724600-1447263848_thumb.p

post-14021-0-39066900-1447263874_thumb.p

Pour réduire la taille des photos depuis iPhoto : sélectionner toutes les photos, puis fichier/Exporter. Dans la fenêtre qui s'ouvre, régler la taille/Personnaliser, puis dans dimensions max largeur, rentrer par exemple 1980.

Link to post
Share on other sites

Désolée de devoir insister mais j'affirme et confirme que ces photos n'ont pas été traitées du tout, ce sont les originales...Alors après, comment expliquer les différences, cela, je ne saurai le dire...Après, peut-être que je ne comprends pas ce que tu entends par "traitées", auquel cas il faudrait préciser...

D'accord, j'essayerai de réduire la taille avec iPhoto ou Aperçu...

Merci en tout cas de prendre le temps de discuter et de chercher le souci...C'est vraiment bien de pouvoir échanger...

Link to post
Share on other sites

Désolée de devoir insister mais j'affirme et confirme que ces photos n'ont pas été traitées du tout, ce sont les originales...Alors après, comment expliquer les différences, cela, je ne saurai le dire...Après, peut-être que je ne comprends pas ce que tu entends par "traitées", auquel cas il faudrait préciser...

Tes photos ont forcément subi des modifications et ont été forcément exportées (mal) puisqu'elles ont perdu leurs informations exif (informations qui sont enregistrées par l'appareil photo en même temps que la photo, quel que soit la marque ou le type d'appareil photo).

Mais le problème ne provient sans doute pas de là.

Comme YANIK le signale, les choses ont changé sous iMovie, depuis l'installation d'El Capitan. Et il est possible que la gestion d'un certain nombre de paramètres système (dont la RAM) ait effectivement changé.

Une première 'mise à jour' devrait sortir sans tarder puisque la bêta de la mise à jour suivante est déjà sortie.

Concernant tes photos, on a pu vérifier, tant chez YANIK que chez moi, que celles que tu nous a mises au téléchargement ne posent aucun problème.

Il y'a donc un problème spécifique à ta machine. Pourrais-tu nous en dire plus car tu es très discrète sur ce point. Nous savons juste que tu tournes à 2 Go ? de RAM ?

En tous cas, essaie de réduire comme je te l'ai indiqué la taille des photos qui ne passent pas et vois ce qui se passe.

Bon courage…

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

Important Information

j'accepte les cookies de ce site. Terms of Use